In order for our Polyshot Calculator to run properly, you will need to have the latest version of Macromedia Flash Player 7 plugin installed on your computer. It is available as a free download from Macromedia.